Intermittent SSO unavailability due to downstream outage

Incident Report for 1Password

Postmortem

Incident Postmortem - Intermittent SSO Availability

Date of Incident: 2025-07-14
Time of Incident (UTC): 22:00UTC - 11:23UTC
Service(s) Affected: SSO
Impact Duration: 1 hour and 23 minutes

Summary

On July 14, 2025 1Password’s SSO services were intermittently slow or unavailable for approximately 1 hour and 23 minutes. This was due to an outage with an upstream provider which 1Password backend services rely on to verify DNS lookups for SSO authentication. You can read the provider’s incident report here, which outlines in detail what occurred and how they remediated the issue. 

For the duration of the incident 1Password customers would have experienced failed or slow SSO login attempts. We apologize for any inconvenience this issue may have caused our users. 

Impact on customers

Customers accessing 1Password cloud services experienced delayed responses and timeout error messages.

  • SSO Login: Users logging in via SSO experienced failures, timeout errors or slow responses

Scope

  • Number of affected Customers (approximate): Most users attempting to authenticate using SSO
  • Geographic Regions Affected: All

What Happened?

At 22:00UTC on July 14, 2025 1Password engineers were alerted to customer timeouts and failures when trying to use SSO as an authentication method. After diagnosing the issue, engineers discovered the source of the issue was an outage with an upstream provider when looking up and verifying OIDC provider hostnames. 

  • Timeline of Events (UTC):

    • 22:00 - Incident initially detected by 1Password 
    • 22:13 - Upstream provider identifies issue
    • 22:59 - Upstream provider implements a fix
    • 23:30 - Incident resolved
  • Root Cause Analysis: The third party provider 1Password uses for DNS lookup and verification failed.

How Was It Resolved?

  • Resolution Steps: Our third party provider mitigated the issue. 
  • Verification of Resolution: We closely monitored systems to ensure SSO logins were successful.

What We Are Doing to Prevent Future Incidents

  • We are investigating the addition of an additional DNS provider to provide redundancy.
Posted Aug 07, 2025 - 11:10 EDT

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 19:30 EDT

Monitoring

The downstream provider has deployed a fix. We are seeing reduced failure rates and will continue to monitor the results.
Posted Jul 14, 2025 - 19:05 EDT

Investigating

SSO logins are impacted due to a downstream provider experiencing a major outage that is impacting our authentication services. Our internal systems are operational, but are intermittently failing due to this downstream dependency. We are monitoring the provider's status and will post updates as they become available.
Posted Jul 14, 2025 - 18:56 EDT
This incident affected: USA/Global (SSO (Single Sign On)), Canada (SSO (Single Sign On)), Europe (SSO (Single Sign On)), and Enterprise (SSO (Single Sign On)).