The original issue remains mitigated. Our engineering team is continuing to address the root cause.
Posted Jul 22, 2025 - 22:17 EDT
Monitoring
Our engineering team has mitigated the issue, and all events should now be returned properly.
Posted Jul 21, 2025 - 15:29 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 21, 2025 - 14:04 EDT
Identified
Our engineering team has identified the root cause and is actively working on a resolution. In the meantime, customers may continue to experience delays in event delivery.
Posted Jul 21, 2025 - 12:42 EDT
Update
Our teams are continuing to investigate this issue.
Posted Jul 21, 2025 - 11:26 EDT
Investigating
Our engineering and product teams are aware of reporting delays regarding the Events API. The data is still being collected but is not currently being reported on.
Posted Jul 21, 2025 - 10:57 EDT
This incident affected: USA/Global (Events API and Reporting).