The engineering team released a mitigation to production and MSP users should be able to access Managed Companies successfully. We will continue to monitor performance.
Posted Oct 28, 2025 - 21:06 EDT
Update
The engineering team is in the final stages of releasing the mitigation to production.
Posted Oct 28, 2025 - 19:59 EDT
Update
The engineering team tested the mitigation and is in the process of releasing to production. We will provide our next update by 20:00 EDT.
Posted Oct 28, 2025 - 18:52 EDT
Update
The engineering team is deploying a mitigation.
Posted Oct 28, 2025 - 18:27 EDT
Update
The engineering team is preparing to deploy a mitigation.
Posted Oct 28, 2025 - 17:50 EDT
Update
The engineering team is continuing to work on a mitigation.
Posted Oct 28, 2025 - 17:22 EDT
Identified
We identified the issue and the engineering team is working on a mitigation.
Posted Oct 28, 2025 - 16:58 EDT
Investigating
We are actively investigating an issue where MSP users may experience a continuous loading screen when trying to access Managed Companies.
Posted Oct 28, 2025 - 16:41 EDT
This incident affected: USA/Global (Admin console).