SaaS Manager performance is degraded

Incident Report for 1Password

Resolved

This incident has been resolved.
Posted May 16, 2026 - 16:36 EDT

Monitoring

Issues with file uploads and downloads, pages not loading, and errors affecting some integrations and workflows are now resolved. Customers may still experience issues with images loading properly, and our engineering team is actively working to resolve them. We expect further progress and resolution later today. The issue affected both the US and EU regions.
Posted May 16, 2026 - 13:46 EDT

Identified

The issue has been identified, and our engineers are working on a fix.
Posted May 16, 2026 - 13:33 EDT

Investigating

Files can not be uploaded or downloaded, and images may not be loading properly. Pages within the application may not be loading. Some integrations and workflows may have experienced errors. This issue affects the US and EU regions. Our engineering team is currently investigating.
Posted May 16, 2026 - 11:51 EDT