1Password Website Forms Experiencing delays

Incident Report for 1Password

Resolved

Our 3rd party provider deployed a fix and we are no longer seeing delays in submission processing. This incident has been resolved.
Posted Jul 02, 2025 - 11:17 EDT

Identified

We’ve identified an issue with a 3rd party provider causing delays on the processing of submissions on the 1Password marketing forms. Our team is currently investigating the issue with our 3rd party provider. In the meantime, expect delays in our automated responses, and if you need to speak with someone now, please contact business@1password.com. Forms affected:

-Webinars
-Content Downloads
-Newsletters
-Contact Sales
Posted Jul 01, 2025 - 13:31 EDT
This incident affected: USA/Global (1Password.com website), Canada (1Password.com website), Europe (1Password.com website), and Enterprise (1Password.com website).